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An Overview of JukeMax

JukeMax is a 256 track Live Performance Sequence Player that is optimised 
for playing back sequences in live performance. It allows you to assemble 
Song Lists. These are lists of Cadenza for Windows songs or standard MIDI 
Files of type one or zero. JukeMax's load ahead feature makes sure that 
you're always ready to play - no waitig for songs to load! JukeMax even lets 
you assign a controller for advancing songs.

JukeMax is intended to be used after a sequence has been created with 
another program, since it has very limited editing. JukeMax's features are 
oriented toward playing sequences back. There are settings for looping 
songs, doing smooth segues between songs and even transposing songs to 
new keys. With JukeMax there's no need to fumble around between songs - 
just load and play.



How to Use JukeMax

JukeMax is designed to be run as a standalone program. It is not intended to 
run with other sequencers. When started, JukeMax displays the song list and 
the transport bar. The transport bar is always displayed. JukeMax has a full 
set of transport controls at the top of the screen for starting record and 
playback. Next to the transport keys is a large Song Position Display. Next to 
the Time Display is the Tempo display.

Before you use JukeMax to play MIDI Files you will need to decide which MIDI 
output to use. MIDI Files have no specification for output. If you only have 
one output on your MIDI interface, then this step is unneccesary. The output 
to use can be set in the JukeMax settings command in the Options menu. For 
Cadenza for Windows format files this is not necessary, since they specify 
outputs for each track.. 

To use JukeMax, you assemble song lists which are queued and played back 
in order. You can also select individual songs for playback, but you will have 
to wait for each song to load. Once you have a song list assembled, you can 
select the first song and press Play to begin playback. JukeMax will load 
several songs ahead ready to play the next song. When a song finishes, 
JukeMax will advance to the next song, ready to play. JukeMax then loads the 
next unloaded song until it runs out of songs to load. 

If a song is assigned a Pause mode, JukeMax will stop after playback and wait
for you to press play to start the next song. If you assigned a song a Segue 
mode, JukeMax will segue smoothly into the next song, like with a medley.    
Assigning a mode of    Vamp to a song causes it to loop continuously until you
press Stop. JukeMax will then position on the next song ready to go.

JukeMax also lets you assign a MIDI controller to take the place of the Play 
and Stop buttons, so that you don't have to be lurking around the computer 
to start the next song. You can simply activate a footswitch instead.



Creating a Song List

To create a song list, load JukeMax and select New from the File menu. You 
will have an empty workspace. Select Compose Mode from the Options 
menu. This will keep JukeMax from loading each song you select. When 
you're done assembling the list you can turn the Compose Mode off to play 
the song list.

Add a song to the list by selecting the "Add Song to List..." from the Songs 
menu. Then choose which type of song you will load, a Cadenza for Windows 
or MIDI File. An Open dialog will then display, allowing you to select the song 
to load. Select a song and load it. For MIDI Files you specify your default 
extention in the JukeMax Settings command in the Options menu. The 
standard extention is .MID but some programs use .SMF.

Once you select a song to load, the Change Song Settings dialog will be 
displayed. It contains settings for Stop Options (or Mode), a Count-in value 
and a Transpose value. 

The Stop option determines what will happen when the song stops. These 
options are Pause, Segue and Vamp and are described above. 

Count-in it lets you put a lead-in between songs. 

Transpose value lets you transpose a file in half steps. This is useful for 
matching keys when segueing songs in a medley. You don't have to change 
the original song.

You can repeat adding songs until you have your whole set list assembled.    If
you accidently add a song you don't want, you can choose    the "Remove a 
Song" command from the Songs menu to delete it from the list. If you want 
to insert a song, select "Insert a Song" from the Songs menu. 

Once the list is assembled, turn the Compose Mode back off and select the 
first song in the list. Start playback and make sure the list plays as expected.
Then make any changes that are necessary. Finally, select the "Save As ..." 
command in the File menu and save your song list. Now you're ready to 
perform.



The Transport Bar

The transport bar has controls for playback as well as displaying the current 
Song Position and Tempo. The transport bar features a standard tape 
recorder style transport consisting of    Play, Stop, Rewind and Fast Forward 
buttons. 

The Play Button starts playback in JukeMax. Stop will stop playback. 
Rewind will wind the current song back to the start. Fast Forward will play 
the song back at a fast speed. The fast forward speed is determined by the 
MIDI Preferences program. 

The large Numeric display is called the Song Position Display. The Song 
Position Display shows the time in the format of Measures:Beats:Ticks.

Next to the Song Position Display is the Tempo Display. This just shows you 
the current tempo, in beats per minute, that the song is playing back at.



The Song List Display

The song list is the area below the Transport Bar. This will display all the 
songs in the current list. The list will display the Song (song's file name), the 
Path (song's directory) ,    Mode (the stop option), Trans(pose),    Count (in), 
and the Load status of the song.

When a song list is loaded no song is selected. To start the playback process 
just select the first song to playback. JukeMax will load the song and load 
ahead the next number of songs. The number of songs to load ahead is 
determined by the "JukeMax Settings" command in the Options menu.

You can modify a song's settings by double clicking the mouse cursor on it, 
or by selecting it and choosing "Modify Song Settings" from the Songs menu. 

You can add a song entry to the end of the list by selecting "Add a Song" 
from the Songs menu or by pressing the Ctrl+D on the PC's keyboard. You 
can insert a song entry at the current position by selecting "Insert a Song" 
from the Song menu or by pressing the PC's Insert key. You can remove the 
currently selected song entry from the list by selecting "Remove a Song" 
from the Song menu or by pressing the PC's Delete key.

The song list displays Song Entries. The actual song is loaded as needed for 
playback. JukeMax loads the number of songs from the currently selected 
song as specified in the Load Ahead setting in the JukeMax Settings dialog. 
The song entry is just a place-holder to tell JukeMax what song to load and 
how to play it. This is important, because an invalid song entry will display an
error message and stop if the song referenced by the song entry is invalid or 
of the wrong format. Before using the Song List in performance you should 
play it after assembling it on the computer you are going to play it live on.



Menu Commands
The JukeMax menu bar has commands for loading and saving mixes, editing 
data, selecting different options and doing cut, copy and paste operations. To
select a menu you just click on the menu title to display each menu.

File Menu 
Songs Menu
Options Menu
Help Menu



File Menu
The File menu contains commands for loading and saving song lists. You can 
also select a command for printing song lists. There is also a command 
storing JukeMax's setup and for exiting JukeMax.

        New
        Open
        Save

Save As...
Add Song List to End...
Save Settings
Printer Setup
Print
Exit



New Ctrl+N

This selection clears the current song list and reloads the default parameters 
from the default setup file. Use this to start fresh to create a new song list.



Open Ctrl+O

Select this command to load an existing song list. When you select this 
command, you will be given an option to save changes, if any, to the current 
song list. The File Open dialog is then displayed.

The File Open dialog has an Edit field for the name of the song list file to 
load. Below that are the list boxes for any existing sequence files and a list 
box for the drives and directories. The default file extension for JukeMax song
lists is ".JML", and only files with the correct extension will be displayed in the
file list.

You can select a song list by either typing its name in the File Name Edit 
field, or by clicking on its name in the Files list. Once you've selected a file 
press the Ok button to load it. A Load dialog will be displayed tracking the 
load progress. If you press Cancel instead of Ok, then no file will be loaded. 



Save Ctrl+S

This selection will save the current song list to disk with the same file name 
as when it was loaded. If you try to save a new song list, the Save command 
will automatically activate the Save As ... command to give you a change to 
give the song list a name.



Save As... Ctrl+A

The Save As... command gives you an option to name the current song list 
before saving it. It displays the Save dialog, which is laid out exactly like the 
Open dialog. Enter a name for the song list in the File Name field. Don't 
forget to add the ".JML" for the song list extension so it will be displayed in 
the Open dialog.



Add Song List to End...

This allows you to add one song list to another. The first song in the new list 
is added after the last song in the current list. You can use this command to 
add as many song lists as needed to create the new longer list.



Save Settings

This option lets you store the current settings of the Options menu to the 
JukeMax initialization file. This file is called    "JukeMax.ini". These settings are
automatically loaded each time JukeMax is loaded.



Printer Setup

This command brings up your default printer's Setup dilog box.



Print Ctrl+P

This options prints a listing of the current song list. Now you can have a song 
list on stage that everyone can read!



Exit

Lets you leave JukeMax. If the current song list has not been saved, you will 
be given an option to save it before exiting.



Songs Menu

The Songs Menu contains commands for changing song entry settings. It also
contains commands for adding and removing song list entries.

Modify Song Settings ...
Add Song to List
Insert Song into List
Remove Song from List



Modify Song Settings ...

The Modify Song Settings command lets you change several options for a 
song list entry. When activated, this command displays the Change Song 
Settings dialog. 

The dialog contains settings for Stop Options (or Mode), a Count-in value and
a Transpose value. The stop option determines what will happen when the 
song stops. These options are Pause, Segue and Vamp and are described 
above. Count-in lets you put a lead-in between songs. 

Transpose value lets you transpose a file in half steps. This is useful for 
matching keys when segueing songs in a medley. You don't have to change 
the original song. If you set a Drum Channel and Port value in the JukeMax 
Settings dialog, Jukemax will leave your drum channel alone.

If a song is assigned a Pause mode, JukeMax will stop after playback and wait
for you to press play to start trhe next song. If you assigned a song a Segue 
mode, JukeMax will segue smoothly into the next song, like with a medley.    
Assigning a mode of    Vamp to a song causes it to loop continuously until you
press Stop. JukeMax will then position on the next song ready to go.



Add Song to List Ctrl+D

This command lets you add a new song entry to the end of the list. When 
you select this command, JukeMax displays a dialog box asking whether you 
want to load a Cadenza for WIndows song or a MIDI File. An Open dialog will 
then display, allowing you to select the song to load. Select a song and load 
it. For MIDI Files you specify your default extention in the JukeMax Settings 
command in the Options menu. The standard extention is .MID but some 
programs use .SMF.
After the song is loaded, the Change Song Settings dialog is displayed 
allowing you to set the song entry's initial settings. See the the Modify Song 
Settings command for its use.



Insert Song into List Ins

This command works just like Add Song to List, except that it inserts the song
entry into the list. The song entry is inserted at the position of the currently 
highlighted song instead of at the end of the song list.



Remove Song from List Del

This command removes the currently highlighted song list entry.



The Options Menu

The Options menu sets various program-wide options, plus selections for 
MIDI Ports used, the current record mode and starting the MIDI Control Panel.

JukeMax Settings ...
Compose List Mode
MIDI Echo
Metronome

        MIDI Control Panel



JukeMax Settings ...

This command lets you set how JukeMax will behave and operate. The 
JukeMax Settings dialog has selections for which MIDI controller to use to 
trigger playback and stop, the MIDI output for MIDI Files to be played on, how
many Songs to Load Ahead, and the default MIDI File extention to use when 
loading MIDI Files.

The Continue on Controller is the controller used to trigger playback and 
record. Below this are settings for the MIDI Input and the MIDI Channel to 
receive controller messages from.

The Send MIDI File to Output selection lets you choose which MIDI output 
MIDI Files will be played back on. MIDI Files don't contain port selections. If 
you need to specify port selections, load your MIDI File into SeqMax or 
Cadenza for Windows and specify your output selections; then re-save the 
song as a CadWin file.

The Songs to Load Ahead parameter specifies the number of songs from the 
current song that JukeMax will load ahead. This lets you qeue up songs so 
that you don't have to wait between songs for the next song to load. This 
also assists the segue feature, since the next song has to be loaded for a 
smooth segue. The setting of this parameter is determined by how long the 
songs you play are and by how much memory you have in your computer.

The MIDI File Extention is a convenience to allow you to specify an extention 
to use for MIDI Files. ".MID" is the default extention, but some older DOS 
programs use ".SMF" for their MIDI File extention.

The Drum Output specifies the output port your drum sounds are played to. 
See Drum Channel below.

The Drum Channel parameter lets JukeMax know which channel your drums 
are played on. When you transpose a song, MIDI information on the Drum 
Channel and Port is not transposed. This lets you adjust the key of a song 
without changing your drum notes. This parameter does not change the 
channel your drums are playing on. It is the way you can tell Jukemax what 
channel you use to play the drums sounds on so transpose can ignore them.

The Ok button accepts the changes and the Cancel button reverts back to 
the settings before this command was executed. To save these settings for 
the next session, select the "Save Settings" command from the File menu.





Compose List Mode

This option lets you tell JukeMax not to load any songs. Each time a new song
list entry is selected, JukeMax attempts to load its song. This can be 
annoying when you are trying to add song list entries or modify their 
settings. When this menu command has a check by it, the Compose mode is 
turned on.



Load Ahead

This command turns the Load Ahead mode on and off. When on, JukeMax 
uses the value set in the JukeMax Settings dialog for Load Songs Ahead to 
load that number of songs from the current selection on. If you are not using 
JukeMax to play from the beginning of the the list to the end this should be 
turned off. This will let you select songs one song at a time.



MIDI Echo

This command tells the MIDI Director to send all events from your MIDI 
interface's input to the MIDI output. This is useful for controlling several 
sound modules from a MIDI keyboard attached to the interface's MIDI input.



Metronome

This activates the MIDI Director's metronome feature. This is useful for 
sending a click track to your drummer or other musician to keep in time with 
the playing song.



MIDI Control Panel

This option starts the MIDI Director Control Panel. In the MIDI Director Control
Panel you can change settings for the metronome, whether MIDI Clocks are 
transmitted during playback and several other useful settings that effect all 
programs that run on the MIDI Director. 

For more information about the MIDI Director Control Panel see the MIDI 
Director Reference.



Help Menu
The Help menu contains selections for accessing on-line help from within 
JukeMax as well as a selection for showing JukeMax's About box.

Index
Keyboard
Using Help
About



Index F1

The Index commands shows you an index of the topics available for help.



Keyboard

This selection shows you the keyboard commands available in JukeMax.



Using Help

This command brings up the help file for the Windows Help Program, which is
used to show JukeMax's help file. It will instruct you on how to move around 
and use the Windows Help engine.



About ...

The About selection shows JukeMax's About dialog. This dialog displays 
programmer credits, your serial number, the version number and the 
copyright information on JukeMax.

 



Keystroke Equivalents

JukeMax uses the mouse for most operations, but sometimes it is more 
convenient    and is faster to use the PC keyboard. This section lists the 
keystroke equivalents for many operations.

Function Keys
KEY OPTION

F1 Help
F2 Play
F4 Stop
F5 Rewind
F6 Fast Forward
F10 Activate Menu Bar

UpArrow
DownArrow Up and down arrows move up or down an entry in the Song
List.
Home Moves to the top of the the Song List.
End Moves to the end of the the Song List.
PageUp Moves up on screen full of entries in the the Song List.
PageDownMoves down on screen full of entries in the the Song List.
Insert Inserts entries in the the Song List.
Delete Deletes entries in the the Song List.
Spacebar Activates Play when in stop mode, Stops when in play mode.

Ctrl+A Save As ...
Ctrl+N New
Ctrl+O Open
Ctrl+S Save
Ctrl+P Print Song List
Ctrl+D Add Song to List

Alt Activates the Menu bar.

Alt+underlined key Activates menu bar menu, whose title contains the 
corresponding underlined character. Moves the cursor to the
item with the corresponding underlined character in dialogs.



Alt+F4 Exit JukeMax



Glossary
Aftertouch Additional pressure applied to a key after a note is started. 
Channel Aftertouch affects all notes on a channel, while Key Aftertouch, also 
called Key pressure, only affects one pitch.

Bank Select Bank select allows you select among several sets of program 
change groups. Since MIDI only defines 128 program changes per MIDI 
channel, bank select is used to expand this number to over two million 
choices. In reality, most instruments have less than 10 banks, with the 
majority only having one bank of program changes.

Block Marking Marking is selecting a group, or block, of items on the 
screen. The block marked area on the screen is displayed in reverse video. 
Block marks are used to limit the range and effect of the edit commands.

Click Press the left or right mouse button once

Ctrl+Click Press the mouse button down, while holding the Control (Ctrl) key
down.

Controller, or Control Change A controller is a way of instructing an 
instrument to turn its volume up, pan the stereo image of the sound, add 
more of an effect or simulate a sustain pedal when using a piano sound. The 
uses of controllers are so varied that no instrument uses all controllers, so 
you need to look at your instrument's MIDI implementation charts to find out 
which Controllers you instrument uses.

Drag Moving the mouse while holding the left mouse button down.

Double-Click Press down a mouse button twice rapidly.
Duration The length of a note.

Events An Event, or MIDI Event, is a message sent by a keyboard to the 
computer. These messages represent notes and control the MIDI equipment 
that when sent to an instrument play the same action back.

Key Pressure Additional pressure applied to a key after a note is started. 
Key Pressure, also known as Aftertouch, only affects one pitch.

MIDI An acronym that stands for Musical Instrument Digital Interface, the 



standard way that modern electronic instruments communicate with each 
other and with computers.

MIDI Echo Also known as MIDI Thru, MIDI Echo is the action of sending all 
data received at the MIDI input to the output in realtime. This is convenient 
for monitoring a performance.

MIDI Event A message sent between various MIDI devices to cause a note 
to be played or some action to be taken.

MIDI Channel A logical division for MIDI messages. MIDI is like a network 
and MIDI channels act like addresses. Each part to be played by an 
instrument is assigned a different MIDI Channel.

Mouse Cursor The pointer on the screen, which is most often an arrow 
shape, that is used to select an item on the display.

Open In windows to load data or activate a program or window.

Overdubbing To add more notes to already existing notes in a track.

Pitch Bend Also known as Bender, pitch bend is generally used to simulate 
the way a guitarist bends a string to stretch a pitch.

PPQN Pulses Per Quarter Notes. The resolution used for one quarter note, 
which is 480 ticks for all MIDI Director applications.

Program Change Also known as Patch change, program change tells an 
instrument to select a new sound or setup.

Resolution The accuracy with which notes are timed.

Select To click the mouse with the cursor over a screen item.

Shift+Click Press the mouse button down, while holding the Shift key down.

Song Position The song position is a way of representing a place in time in 
the song. Song Position is represented in Ticks in a Measure:Beat:Tick format.

System Exclusive A manufacturer specific way of representing data that is 



used only by that manufacturer's instrument. System exclusive can be used 
to transfer sound data, change effects settings or change the basic tuning of 
an instrument.

Window A window is a retangular area on the screen that is used by a 
program to display information and receive information. You should read your
Windows user's guide for an understanding of Windows and the concepts of 
how to use them.



Error Messages
Can't Load Control Library File (BNCTRL.DLL)
Can't Load MIDI Director Library File (MIDIDIR.DLL)
Can't Load MIDI Director Control Panel.

One of the Control Files needed to run MixMax or FadeMax is missing. Try 
reinstalling from the original program disks.

Can't Find the Digital Font File.
Can't Create the Digital Font. You might be out of Windows Resources.

One of the Font Files needed to run MixMax or FadeMax is missing. Try 
reinstalling from the original program disks.

Out of memory Loading Sequence
Error Locking Sequence Memory

There isn't enough memory left to load the sequence. Try decreasing the 
Load Songs Ahead value.

Problem writing to Disk. Is there enough room ?
You must be out of disk space.

List File Read Error!
List File Read Error! Invalid List Header.
File Read Error! File is the wrong length. File may be Corrupt!

The song list file must be corrupted. Hope you've got a backup or a 
printout!

List File Read Error! Can't Allocate Temporary Song Entry.
List File Read Error! Can't Allocate New Song List Entry!

There probably isn't enough memory.

Problem Accessing Printer
Unable to start print job

Is your printer on line? Does it have paper ? have you selected a valid port
for your default printer.

Can't Display Print Status window
You're probably out of memory or have too many programs running.

Cadenza for Windows File Read Error
Invalid Cadenza for Windows File. Cadenza for Windows Header Signature 
is Invalid.



Can't Allocate Cadenza Tempo Map.
The file you are trying to read is either damaged or is not a Cadenza for 
Windows format file.

Can't Read SMPTE Encoded MIDI Files.
JukeMax can't play SMPTE encoded MIDI Files.

Can't Allocate Tempo Map
You're probably out of memory.

MIDI File must be Type 0 or 1
JukeMax can't read type 2 MIDI Files.

Invalid MIDI File - Can't Find MIDIFile Header.
You're trying to read a file that is not a valid MIDI File.

Sync Error reading MIDI File.
Unknown Data in File. Aborting.

The MIDI File you're trying to read is corrupted.



Information and Trivia

Timer Resolution
The MIDI Director uses a tick rate of 480 ticks per quarter note. It also 
generates a millisecond based reference clock.

Maximum Number of Running Programs
The number of MIDI Director programs that can be run is between eight and 
sixteen programs. Most sequencers use two data streams, but other 
programs, such as LibMax the Generic Librarian only use one.

Maximum Number of MIDI Interfaces
The number of MIDI Ports the MIDI Director supports is sixteen MIDI inputs 
and sixteen MIDI outputs. These MIDI Ports can be on any combination of up 
to eight physical interface cards.

Filenames and Extensions used by JukeMax
JukeMax uses the following file extensions. Each extension is listed with the 
kind of file data it represents.

filename.JML JukeMax Song List file. 
filename.SNG Cadenza for Windows format song file. Can also be 
produced by SeqMax.
filename.MID Standard MIDI File. JukeMax will read and play type 1 and 0
MIDI Files. 




